ro d bl U e RSS Version 94.0.2 Release Notes

Release Date: 16 June 2025

This release:

e Resolved runtime exceptions by explicitly opening and exporting internal Java modules via JVM
arguments.
e Switched the signing certificates for the installer

If you have any ideas for improvement, questions, or issues let us know at support@radblue.com.

Case Description
20504 | Missing JVM options for Java 21 causes security exceptions
20509 | Switch signing certificate for installer
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ro d bl U e RSS Version 90.0.0 Release Notes

Release Date: 4 June 2024

This release:

e Upgrade Java to 21

If you have any ideas for improvement, questions, or issues let us know at support@radblue.com.

Case Description
20259 | Upgrade Java to 21
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ro d bl U e RSS Version 88.0.0 Release Notes

Release Date: 6 December 2023

This release:

e Upgrade Javato 17.0.9.9

If you have any ideas for improvement, questions, or issues let us know at support@radblue.com.

Case Description
20130 | Upgrade Java to 17.0.9.9
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ro d bl U e RSS Version 86.0.0 Release Notes

Release Date: 6 June 2023

This release:

e Upgrade Java to 17.

If you have any ideas for improvement, questions, or issues let us know at support@radblue.com.

Case Description
19643 | Upgrade RSS to Java 17
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ro d bl U e RSS Version 84.0.0 Release Notes

Release Date: 6 December 2022

This release:

e Upgrade Java to 1.8.0_352.

If you have any ideas for improvement, questions, or issues let us know at support@radblue.com.

Case Description
19375 | Upgrade Java to 1.8.0_352
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ro d bl U e RSS Version 82.0.0 Release Notes

Release Date: 27 June 2022

This release:

e Converted to Log4j2

If you have any ideas for improvement, questions, or issues let us know at support@radblue.com.

Case Description
18867 | Replaced logdjl.x with log4j2 version 2.17.2. In light of security issues associated with
CVE-2021-45046, we decided to review log4jl.x usage and replace it with the latest

version of log4j2.
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ro d bl U e RSS Version 80.0.0 Release Notes

Release Date: 7 December 2021

This release:

e Fixed a user interface bug where the file menu was not being fully displayed.

If you have any ideas for improvement, questions, or issues let us know at support@radblue.com.

Case Description
17522 | File menu not showing all items.
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ro d bl U e RSS Version 78.0.0 Release Notes

Release Date: 2 June 2021

This release:

e Updated Javato 1.8.0_275
e Updated JIDE to 3.7.12-pre
e Updated JXBrowser to 7.12

If you have any ideas for improvement, questions, or issues let us know at support@radblue.com.

Case Description
17157 Update Java to 1.8.0_275
17158 Update JIDE to 3.7.12-pre

17159 Update JXBrowser to 7.12
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ro d bl U e RSS Version 76.0.0 Release Notes

Release Date: 7 December 2020

This release:

e Added support for GAT in S2S 1.6 and S2S 2.0.
e Updated Apache CXF to 3.2.13

If you have any ideas for improvement, questions, or issues let us know at support@radblue.com.

Case Description
16707 | Updated Apache CXF to 3.2.13.
16755 | Starting a web server to handle help files to work around a limitation in FireFox.
16936 | Added support for gat.getVerificationStatus and gat.getComponentList.
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ro d bl U e RSS Version 74.0.0 Release Notes

Release Date: 2 June 2020

This release:

Added support for GAT extension in S2S 1.6 and S2S 2.0.
Updated Java to OpenJDK 1.8.0_242.

If you have any ideas for improvement, questions, or issues let us know at support@radblue.com.

Case Description

16392 Updated Java to OpenJDK 1.8.0_242.

16394 Moved the G2S WSDL to allow student licenses to work.
16609 Added support for GAT extension in S25 1.6 and S2S 2.0.
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ro d bl U e RSS Version 70.0.0 Release Notes

Release Date: 3 June 2019

This release:

e Fixed a bug with web browser cookies.
e Replaced deprecated JavaFX web browser

If you have any ideas for improvement, questions, or issues let us know at support@radblue.com.

Case Description
14904 | ArrayindexOutOfBounds exception when cookie had an empty error text.

14936 | Switched web browser that is embedded in the RSS since Oracle is no longer
supporting JavaFX in the JRE/JDK distributions.
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ro d bl U e RSS Version 68.0.0 Release Notes

Release Date: 3 December 2018

This is the last release of the Windows 32-bit installer. Oracle is no longer supporting 32-bit
Java installations.

This release:

e Added support for clientinfo, and playerBonus in S25 2.0.0.
e Added support for clientType in S25 1.6.0 and 2.0.0.
e Added Windows 64-bit installer.

If you have any ideas for improvement, questions, or issues let us know at support@radblue.com.

Case

Description

14555
14556
14557
14558
14559
14576

14580
14628
14631

14647

14874

Created S2S 2.0.0 schema for use in RSS

Added scripts for 525 2.0.0

Added clientInfo class support in S25 2.0.0

Added playerBonus class support in $2S 2.0.0

Added support to RSS installer to install new scripts

Fixed a bug where the RSS Edge script stops working when saving communications
response configuration.

Added clientType class support in S25 1.6.0 and 2.0.0.

Added missing clinetInfo client types to S2S 1.4.0 and 1.6.0.

Added a feature to scroll to the last used command when returning from sending
a command.

Added non-standard clientinfo commands to the central host script that should be
only access from the edge script.

RSS Windows 64-bit installer.
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ro d bl U e RSS Version 64.0.0 Release Notes

Release Date: 4 December 2017

In this release,

e Upgraded Java to 1.8.0_152.

If you have any ideas for improvement, questions, or issues let us know at support@radblue.com.

Case Description

12904 Updated Java to 1.8.0_152.
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ro d bl U e RSS Version 62.0.0 Release Notes

Release Date: 1 June 2017

In this release,

e Added support for PKCS11 tokens such as SafeNet’s eToken 5105.
e Fixed an issue where TLS clients in RadBlue tools would not negotiate TLSv1.1.

If you have any ideas for improvement, questions, or issues let us know at support@radblue.com.

Case Description
12470 | TLSv1.1 support was disabled by default in Java 8 and therefore not enabled in the
RadBlue tools. RadBlue tools now explicitly enable TLSv1, TLSv1.1 and TLSv1.2.
12688 | The user interface gave the impression that the SCEP polling interval could be set
as low as one second. The user interface has been changed so that 30 seconds is
the minimum SCEP polling interval allowed.
12773 | Added support for PKCS11 token as the certificate store for TLS communications.

PCKS11 token support

The token is used as the security storage of the private key and public keys that are used in encrypted
communications between the S2S host and the RSS.

Prerequisites
1. Before the RSS can be configured to use a PKCS12 token, the token MUST be configured in the
operating system. Please verify that the token is accessible in the operation system and working
as expected.

2. Determine the PKCS12 shared library that is used to access the token from the operating
system. For example, c:\Windows\Systems32\eTPKCS11.dll is the library file for SafeNet’s
eToken 5105.
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CVT Version 17 Release Notes

Procedure
Select Tools > Configure > . .
. . Security Options
Securlty Optlons' General | Certificates | Key Store

1. Select Enable PKCS11
Token option.

2. Verify that the PKCS11
Token Shared Library is
set correctly.

3. Ifthe token hasa
password, then enteritin
the PKCS11 Token
Password field.

Require Client Certificates

Enable SSL security control

Security Environment

[] Use Minimum Security Environment

PKCS11 Token Options

.
PKCS11 Token Shared Library : | C:\Windows\System32\eTPKCS 11,41 |} Select

PCKS11 Token Password @ | password

QCSP Options
[] Enable ocsP

QC5P Server Location :

Re-Authenticate Certificate Every (gsaCR) : 9600 2 | Minutes

QCSP Server Considered Offline After {gsa00) : e 12| Minutes

Note: if the token does not Accept Previously Good Certificate for (gsaOA) : 630 7 | Minutes
have a password then set the
password to an empty string.

Click Apply and click OK. Restart required for changes e

Restart RSS (File > Exit) and
then double click the RSS icon.

Verify that the token can be
read by RSS by reviewing the
key store tab in the Security
Options and verifying that at
least one of the aliases is a key
entry.

(Tools > Configure > Security
Options > Key Store)

Security Options
General | Certificates” Key Store
Select Key Store File

Client Key Store £ Refresh

Default Alias:  <not set= @ SetasDefault [l Import [l Export 3 Remove
Alias Issuer Is Key Entry

aal CN=T A0 e " Qe L w ... false

ZIR CM=1" ... false

o CN=C/e =0 Sl el frue
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ro d bl U e RSS Version 60.0.0 Release Notes

Release Date: 5 December 2016

In this release,

e Upgraded Java runtime to 1.8.0.112.

If you have any ideas for improvement, questions, or issues, just let us know at support@radblue.com.

Case Description

12042 Update Java runtime to 1.8.0.112.
12126 Fixed an issue with the wrong version of STAX2 API jar file being installed.

12132 Fixed an issue where the S2S message summary was not being calculated
properly.
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ro d bl U e RSS Version 58.0.0 Release Notes

Release Date: 23 August 2016

In this release,

e Added support for missing commands in clientEvents class.

If you have any ideas for improvement, questions, or issues, just let us know at support@radblue.com.

Case Description

11520 Debug.zip file now includes the bin directory to determine which VMOPTIONS were in
effect when the debug.zip file was created.

11586 Added support for missing clientEvents commands in the Edge system.

11587 Added support for missing clientEvents commands in the Central system.

11588 Fixed the logging to separate Edge for Central logs.

11660 Fixed a bug where an ampersand in the company name caused the RSS script to fail.
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ro d bl U e RSS Version 56.0.1 Release Notes

Release Date: 31 May 2016

In this release,

e Commands that do not need a response are now sent as notifications in $25 1.6.0.
e Upgraded Java to 1.8.0_74.
e Fixed typos and S2S 1.6.0 scripts.

If you have any ideas for improvement, questions, or issues, just let us know at support@radblue.com.

Case Description

11154 | Upgraded Java to 1.8.0_74.

11383 | Fixed a typo on the systemInfoUpdate panel for $25 1.6.0.

11384 | The file name for setinfoUpdateSubList panel was fixed in S2S 1.6.0.

11385 | Host commands that don’t need a response are now sent as notifications. Previously,
they were sent as requests.

11386 | Fixed getCompAvailability so that the script does not exit when the command is received
in $25 1.6.0.

11387 | Fixed activeRatingReq so that the script does not exit when the command is received in
§251.6.0.

11388 | Fixed a typo in the issueVoucherReq panel for S2S 1.6.0.

11389 | Edge command that don’t need a response are now sent as notifications. Previously, they
were sent as requests.

11410 | RSS will not start with an invalid license. The user can load a new license or exit.
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ro d bl U e RSS Version 54.0.0 Release Notes

Release Date: 01 March 2016

Case Description

7222 | SOAP client has been configured to maintain keepAlive messages for longer than 5
seconds. A new RSS.VMOPTIONS option has been added to configure the HTTP client.
109671 | Date format in postFinancialTransaction has been corrected. An error in which cashTrans
was not a child element of financialTrans has also been corrected.

10976 | RSS now supports financial transactions in the central server.

10983 | Explicitly enabling TLSv1, TLSv1.1 and TLSv1.2.
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