rO d bl U e RPA Version 36 Release Notes

Release Date: 10 DEC 201

Release Summary

In this release, we added support for PKCS #12 files for importing key store files, added strike-through
font for attributes that are deprecated in G2S 2.1 on the Message Transcript detail screen and made
usability improvements.

Configuration Modifications

3

o Anew Import PKCS #12 [ 6 scoe confiation SN e

File option (Tools >
Configure > Security General | Certificates” Key Store
. Select Key Store Fj

Options > Key Store) lets ' ]
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All certificates in the PKCS Once you import a PKCS #12 file, the key store files
#12 file are imported to are are added to the list of key store files.
client.jks. Only non-key-entry You can toggle between the list of Client Key Store
certificates are imported to files and Trusted Key Store files by clicking the Select

. Key Store File drop-down arrow.
trusted.jks. Once the

certificates are successfully Import PKCS #12 File

. . File: |C:\UsersiDesktoplexample.p12 || Browse

imported, they can be viewed — . T import
: passwor

from the Key Store tab.

User Interface Modifications

o Error messages that display in the GSA Message Validator, accessed through the Tools option
on the menu bar, have been improved with clearer information when XML is invalid or the G2S
message does not conform to the protocol.

¢ The performance of the Debug Console has been improved to display messages more efficiently,
especially during long runs of the tool.
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RPA Version 36 Release Notes RadBlue Protocol Analyzer

Advanced Transcript Analyzer Modifications

e The Summary version of the Advanced Transcript Analysis Report now displays one incident of
each error type for each communications session.

Transcript Modifications

o Attributes that have been deprecated in G2S 2.1 now display in a strike-through font in the
Message Transcript detail screen's Command view. The command details screen can be accessed
by double-clicking any message in the Message Transcript.

~ Transcript Message [ID: 2607] - communications.commsStatus [G25_response]
—

Transcript Message [1D: 2607] -
[ gk [ | ReqResp l l I Transport Message
Transcript M e [ID: 2607] - i

Command | View XML

[G2S_response]

Command ID: 54427

Date/Time:
Date/Time Sent:
Device ID:
EGMID:

HostID:
Session ID:
e e
Session Retry:
Session Type:

Time To Live: 0

Message ID:

2013-10-317 14:56:02.936-07:00
2013-10-317 14:56:02.940-07:00
1

REG_1234

1

300147

b

false

G25_responss

2607
Attributes that have been

P
¢
Z

@ deprecated in G2S 2.1 display ina
Host Enabled:  true
oM Enabled: true strike-through font.
Outhound Overfiow:  false
Inbound Querfiow:  false
G25 Protocol:  true
Comms State:  G25_online
Transport State: G25_traghefBrtUp
e

Config Date/Time:
dierlying Tr:

it State:

<MNot Set>
G25_trar

o Comments associated with a message are now displayed next to the Command and View XML
tabs when you view the message details as well as in the Message Transcript object.

15 P
" Transcript Message [ID: 508797] - progressive. etﬁcgmhepmﬁhm =)

Transcript Message [ID: 508797] - progressive.getProgressiveProfile [625_request]
% MNext

‘ W™ g2sAck || | ReqResp H @TransportMessage @ Previous

Transcript Message [ID: 508797] - progressive.getProgressiveProfile [G2S request]
View XML

Command Comment: MTP Service Initialization

4

Command ID: 158
T THEE T EnTT Comments associated with the message
now display here as well as in the Message
Date/Time Sent:  2013-11-14T11:55:19.208-08:00 . .
Transcript object.
Device ID: 2

N P A W W

e An issue in which the Clear Display option in the Message Transcript cleared the transcript
display as well as the EGM selector list has been corrected. The Clear Display option now clears
the transcript messages from the table only. The Clear Database option removes all transcript
records from the transcript database, clears transcript messages from the table and clears the
EGM selector list.
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rO d bl U e RPA Version 34 Release Notes

Release Date: 01 OCT 2013

Release Summary

In this release, we added the ability to use the existing license when you reinstall RPA, added a new
configuration option and made an improvement to the Message Transcript.

Did you know....

You can use a custom schema file with RPA by placing the schema in the designated directory and
selecting that file through the Engine Options configuration screen. For more information, see
"Install a Custom Schema File" in the RPA User Guide or RPA Help.

Installation Modifications

o For version 34 and higher, if you install a version of RPA over an existing version, you now have
the option of using the existing license. If you do not want to use the existing license, you can
browse to a new license. Note that this option is only available when you install RPA over a
previous installation. All components of the previous installation are removed by the installer
except the license file and any backup files.

MW
Select RGS License o

‘You should have recently received a RGS license fle from RadBlue. Please
select the location of this license file so thatit can be loaded into RGS.

@) Use Existing RGS license

~) Use NEW RGS license

C:\Users\Desktoply34 Browse ...

Configuration Modifications

e A new security option (Tools > Configure > Security Options > General) has been added that
lets you fine-tune certificate requirements for the tool. Select Require Client Certificate if the
other endpoint must have a certificate or it fails authentication. If this option is cleared, the other
endpoint is not asked to send its client certificate. By default, this option is selected.
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RPA Version 34 Release Notes RadBlue Protocol Analyzer

Transcript Modifications

e On the Command tab for the cabinet.setOperatingHours command and the
cabinet.operatingHoursList command, accessed by double-clicking that command in
the Message Transcript, a standard Time value is now displayed instead of a Time value in
milliseconds.
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RPA Version 32 Release Notes

Release Summary

Release Date: 06 AUG 2013

In this release, we updated the required Java version, added support for the hardware class and
enhanced the Message Transcript to allow you to display multiple EGMs at once.

Did you know....

The Advanced Transcript Analyzer lets you easily verify that commands being sent by the

EGM are semantically valid. Visual cues let you easily discern which events have errors. You can
then quickly drill down to the message content level to view the issue. For more information, see

"Using the Advanced Transcript Analyzer" in the RPA User Guide or RPA Help.

New Features

e New for 2.1! RPA now supports the Hardware class.

¢ You can view hardware command details in the Message Transcript.

.

© Transcript Message [ID: 5353] - hardware hardwareDevicelist [GZS_respoﬂse_ [
Transcript Message [1D: 5353] - hardware.hardwareDevicelist [62S_response]

‘ M g2sAck ‘ i | ReqResp ] [ @ Transport Message & Previess  J mext ||

Transcript Message [ID: 5353] - hardware.hardwareDeviceList [G25_response]

Command | view xmL|

Command ID:

Date/Tine:
Date/Time Sent:
Device ID:
EGMID:

Host ID:
Session D
Session More:
Session Retry:
Session Type:
Time To Live:

Message ID:

Command Name:

Last Fardware Change:

41861

2013-06-27T 15:25:40.399-07:00
2013-06-27T15:25:40.400-07:00
1

RBG_1234

1

200153

false

false

G25_response

0

5353

hardware. hardwareDevicelist

2013-05-23T15:58:00,000-07:00

Hardware Groups

Name
G25_sccentlight-1

Vendor ID

Product ID
~Release Number

Vendor Name
--Product Name

Serial Number
~Hardware Description

Device Class
~Device ID

Properties
G25_sceentlight-2
G25_accentlight-3
Vendor ID

Product ID

Release Number
--Vendor Name

Product Name
~Serial Number

Hardware Description
~Device Class

Device ID
-Properties

REG_color

FLRAG funk

Value
RBG
moad light
3.0

838

G25_none
0

RBG
mood light
3.0

890

G25_none
i

m
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RPA Version 32 Release Notes RadBlue Protocol Analyzer

Installation Modifications

o All RadBlue products now require Java SE 7u25 or higher. If the installer cannot find this

version on your computer, you are prompted to download and run the Java installer, or navigate
to the correct Java version. This update should have minimal effect on your environment, but
keeps our products on modern versions of the underlying technology.

Transcript Modifications

¢ In the Message Transcript, the Time column value for the detail view of the

Transcript Message [ID: 791] - cabinet.operatingHoursList [625_response]

@ Previous } Mext

% g2sAck | l *\ Reg-Resp I [ ETransportMessage

Transcript Message [ID: 791] - cabinet.operatingHoursList [G2S_response]
Command | View x|v||_| |

Operating Hours
Command ID: 45256 pereting 1

Operating Hours (
Dste/Time:  2013-07-18T15:57:02.983-07:00 eciny [ flanc St
(GTK_sunday 16:00:00 GTK_enable
Date/Time Sent:  2013-07-18T15:57:02.984-07:00 (GTK_monday 16:00:00 GTK_enable
GTK_tuesday 16:00:00 GTK_enable
Device [0: 526059076 GTK_wednesday 16:00:00 GTK_enable
GTK_thursday 16:00:00 GTK_enable
EGMID: RBG_1234 GTK _friday 16:00:00 GTK_enable
(GTK_saturday 16:00:00 GTK_enable
HostD: 1 N /
Session ID: 200159

Session More:  false

Session Retry:  false

Session Type: G25_response

1 [ n | »

e You can now view multiple EGMS at once in the Message Transcript (rather than one or all) by

holding down the CTRL button and selecting the EGMs you want to view.

50163

50162

50161
50160
2013-07-10T13:28:51.686-07:00 50159
2013-07-10T13:28:51.720-07:00 50158
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rO d bl U e RPA Version 30 Release Notes

Release Date: 04 JUN 2013

Release Summary

In this release, we updated the required Java version, added the ability to import and export
configuration settings and corrected transcript issues.

Did you know....
4 GB is now the minimum Memory requirement for computers running RPA.

Installation Modifications

o All RadBlue products now require Java SE 7ul7 or higher. If the installer cannot find this
version on your computer, you are prompted to download and run the Java installer, or navigate
to the correct Java version. This update should have minimal effect on your environment, but
keeps our products on modern versions of the underlying technology.

User Interface Modifications

o Two new options, accessed through the File option on the menu bar, let you export all RPA
configuration options and import those options into another instance of RPA. With these options,
you can now quickly configure new instances of RPA.

o Export Configuration... - Select to export all configuration settings for the tool, including
security certificates. The resulting ZIP file can then be imported into another version of the
same tool.

o Import Configuration... - Select to import all configuration settings for the tool, exported
from another version of the same tool, including security certificates. This option is used when
you want to quickly set up a specific configuration for the tool that is already set up in another
version of the tool.

Transcript Modifications

o Ifthe tool receives a date/time with the seconds parsed greater than milliseconds, the time/date
is truncated to milliseconds in the transcripts. For example:

The date/time 2013-04-30T08:03:46.1234567890-07:00

displays as 2013-04-30T08:03:46.123-07:00 in the transcript.
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RPA Version 30 Release Notes RadBlue Protocol Analyzer

You can view the longer date/time format on the XML tab of the command object. To access the
command object, double-click any message in the transcript.

e An issue in which the Message Transcript was reporting application errors incorrectly in the
Summary column (for example, when sending an invalid attribute value in a message) has been
corrected. The error is now noted correctly, for example:

optionConfig.error [G2S_OCX013, Invalid Value Selected For Option
- G2S_none is invalid for eventSubscriptions]
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rO d bl U e RPA Version 28 Release Notes

Release Date:02 APR 2013

Release Summary

In this release, we updated the required Java version, updated the Apache CXF version and made a
minor change to the details screen in the Message Transcript.

Installation Modifications

o All RadBlue products now require Java SE 7ul1l or higher. If the installer cannot find this
version on your computer, you are prompted to download and run the Java installer, or navigate
to the correct Java version. This update should have minimal effect on your environment, but
keeps our products on modern versions of the underlying technology.

Engine Modifications

¢ In an ongoing effort to ensure that RadBlue tools use the latest technologies, RPA has been
updated to Apache CXF version 2.7.2. This change should not affect tool performance or
operation.

Transcript Modifications

o The detail screen in the Message Transcript has been streamlined from two View XML options
to one. The View XML button on the Command tab has been removed. To view messages in XML,
click the View XML tab.

T b e e ==
Transcript Message [ID: 7963] - voucher. i [625_response]
WO g2sAck ‘ l | Reg-Resp ] [ £ Transport Messoge & Previoss Next
Transcrij ssage [ID: 7963] - voucher.validationData [G2S5_response]
Commenk View M. )
[3) Text view [1) Hex View
B Find ) Find Next @) Find Previous Hghliaht [] Match Case

0001
0002

<gs 25/schenzs vl 0.5">
< ~07:00" g2s:egmias

0003
000¢
0005
0006
0007
0008

5_1234"

25T13:23:12 061-07:00"

m

2s:velidacionliscTd="100087">
58 s:validat:
ralidat.

ra="30000136
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rO d bl U e RPA Version 26 Release Notes

Release Date: 05 FEB 2013

Release Summary

In this release, we updated RPA to 2013 licenses, and made improvements to security options.

Installation Modifications

o RPA now requires a 2013 license. If you have not received a 2013 license, please contact
RadBlue Support.

Security and Transport Modifications

e An issue in which the default keystore alias was not being saved has been corrected. You can set
the default keystore alias by going to Tools > Configure > Security Options > Keystore, and
clicking Set As Default.

¢ In a testing environment, you now have the option to enable minimum security. This option is
found at Tools > Configure > Security Options.

Security Options

General | Certficates | Keystore

Desktop Options | Enable SSL security control

&
Q Security Environment

Engine Options [ Use Minimum Security Environment

:\) OCSP Options
o)

Enable OCSP
Security Options

©OCSP Server Location :
Re-Authenticate Certificate Every (gsaOR) : 600 - Minutes
OCSP Server Considered Offine After (gsa00) : 1 Minutes

License Manager Accept Previously Good Certificate for (gsa0A) : 6304 Minutes

Cancel

When you enable this option:

e The Transport Layer Security (TLS) 1.0 is the only supported protocol for client-side TLS
sessions. Note that host-side sessions are not restricted.

o The only supported cipher suite is SSL_RSA_WITH_3DES_EDE_CBC_SHA for both client- and
host-side TLS sessions.
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Engine Modifications

« A second-pass-validate attribute has been added to the g2s-schema-metadata.xml. This
attribute is designed to give you a second validation pass to detect syntax errors that are not
found in the first validation pass attribute. Set this attribute to false if the second validation pass
takes too much CPU resources, or the EGM /host is in violation of the G2S schema and you are
unable to fix your code. The default is true.

<?xml version="1.0" encoding="UTF-8"?=
- «<schema second-pass-validation="true" validation="true" nice="true" version="2.1.0">

<loader classname="com.radblue.gsa.g2s.core.types.SchemalLoader"/>
<source root-package="com.radblue.gsa.g2s"/>

- =<command-classpath>

«=classpath value="com.radblue.cvt.commands"/ >

</command-classpath>

- <namespaces:>
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